Thursday, May 14, 2015

VMWare ESXi 6.0 upgrade (from 5.5u2)

First off, I put the all server in maintenance mode.

Then from the burned image .iso file downloaded from the VMWare site (VMware-VMvisor-Installer-6.0.0-2494585.x86_64.iso), boot from the CD on the server, choose upgrade and… everything goes smoothly ! Unfortunately, I still do not have a remote access card to make screenshot from BIOS boot. Anyway, this is really straightforward.

Second, I immediately applied the patch ESXi600-201504001.zip as followed, connected on the ESXi server (ssh) :
[root@hercules:/vmfs/volumes/5549e911-6babde10-89ba-001ec9deb63b/ESXi600-201504001] esxcli software vib update --depot=/vmfs/volumes/5549e911-6babde10-89ba-001ec9deb63b/ESXi600-201504001/ESXi600-201504001.zip
Installation Result
   Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
   Reboot Required: true
   VIBs Installed: VMware_bootbank_esx-base_6.0.0-0.5.2615704
   VIBs Removed: VMware_bootbank_esx-base_6.0.0-0.0.2494585
<…snipped…>
After rebooting the server, verify the patch bundle was installed, by issuing the following command:
[root@hercules:~] esxcli software vib list | more
Name                           Version                               Vendor  Acceptance Level  Install Date
-----------------------------  ------------------------------------  ------  ----------------  ------------
OpenManage                     7.4.0.2.ESXi550-0000                  Dell    PartnerSupported  2015-05-11
mtip32xx-native                3.8.5-1vmw.600.0.0.2494585            VMWARE  VMwareCertified   2015-05-11
ata-pata-amd                   0.3.10-3vmw.600.0.0.2494585           VMware  VMwareCertified   2015-05-11
ata-pata-atiixp                0.4.6-4vmw.600.0.0.2494585            VMware  VMwareCertified   2015-05-11
ata-pata-cmd64x                0.2.5-3vmw.600.0.0.2494585            VMware  VMwareCertified   2015-05-11
ata-pata-hpt3x2n               0.3.4-3vmw.600.0.0.2494585            VMware  VMwareCertified   2015-05-11
ata-pata-pdc2027x              1.0-3vmw.600.0.0.2494585              VMware  VMwareCertified   2015-05-11
ata-pata-serverworks           0.4.3-3vmw.600.0.0.2494585            VMware  VMwareCertified   2015-05-11
ata-pata-sil680                0.4.8-3vmw.600.0.0.2494585            VMware  VMwareCertified   2015-05-11
ata-pata-via                   0.3.3-2vmw.600.0.0.2494585            VMware  VMwareCertified   2015-05-11
block-cciss                    3.6.14-10vmw.600.0.0.2494585          VMware  VMwareCertified   2015-05-11
cpu-microcode                  6.0.0-0.0.2494585                     VMware  VMwareCertified   2015-05-11
ehci-ehci-hcd                  1.0-3vmw.600.0.0.2494585              VMware  VMwareCertified   2015-05-11
elxnet                         10.2.309.6v-1vmw.600.0.0.2494585      VMware  VMwareCertified   2015-05-11
emulex-esx-elxnetcli           10.2.309.6v-0.0.2494585               VMware  VMwareCertified   2015-05-11
esx-base                       6.0.0-0.5.2615704                     VMware  VMwareCertified   2015-05-11
esx-dvfilter-generic-fastpath  6.0.0-0.0.2494585                     VMware  VMwareCertified   2015-05-11
esx-tboot                      6.0.0-0.0.2494585                     VMware  VMwareCertified   2015-05-11
esx-xserver                    6.0.0-0.0.2494585                     VMware  VMwareCertified   2015-05-11
ima-qla4xxx                    2.02.18-1vmw.600.0.0.2494585          VMware  VMwareCertified   2015-05-11
ipmi-ipmi-devintf              39.1-4vmw.600.0.0.2494585             VMware  VMwareCertified   2015-05-11
ipmi-ipmi-msghandler           39.1-4vmw.600.0.0.2494585             VMware  VMwareCertified   2015-05-11
ipmi-ipmi-si-drv               39.1-4vmw.600.0.0.2494585             VMware  VMwareCertified   2015-05-11
<…snipped…>
[root@hercules:~]

The esx-base has been updated with the proper package number 2615704.

Third, on client side, install the last version of ViClient.
image
It is not more than few minutes matter.
The login screen did not change from a bit compared to the previous one, still the warning with VMWare 5.5. I was even wondering if it upgraded at all.
image 
On the license warning, do not forget to apply the new one which has been assigned when you downloaded the product:
image 
“Assign a license to the ESXi” open a web browser to go on VMWare website and get a license number under your registration.
If you downloaded the free product ESXi within your VMWare account, click on OK.
Glad to see ESXi 6.0.
Then go to configuration tab and “Licensed Features” :
image 
Click on Edit, on the top right of the page :
image 
Then assign a key:
image
esxi6_001
Then, confirm it’s ok :
esxi6_002
Ok, now it is not limited in time anymore.

Finally put back the server out of maintenance mode, and reboot for the last time. All the VMs configured to restart automatically should restart. 

image 

Your last step will be to upgrade the VMWare tools onto all the VMs hosted on the ESXi server… I installed recently FreeNAS9.3, no need to manage the VMWare tools, it is guest managed.

image

Amazingly, we can create VM from Windows 3.1 up to 10 which is not even GA…
image
Just a little trick I use, since my OS is in French, ViClient is using French UI. I wanted English, so I run the exe as following :
"C:\Program Files\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\VpxClient.exe" -locale en_US

Nicolas.

1 comment:

Anonymous said...

really XP?